Skip to main content

Java 8 Coding challenge: Swapping Characters



Your are given a string of length N. You have to follow some rounds of swapping in the string until the below explained condition is reached.

In each round the, you have to swap the ith and (i+1)th character , then (i+2)th and (i+3)th character and continue till the end of string. In each round , a character from the left will be locked i.e not available for swapping after this round , thus after some rounds of swapping , all the characters will be locked at their final position to stop any more rounds of swapping .

See the sample explanation for more clarity.

Input

The first line of input contains a T, the number of test case. The first line of each Test case will contain an Integer N , denoting the length of the string. The second line of each Test case will contain a string of length N.

Output

For each and every test case, output the string after all positions are locked.

Constraints

  1. 0<T<100

  2. 0<N<10000






SAMPLE INPUT





2
6
abcdef
3
abc





SAMPLE OUTPUT





bdfeca
bca





Explanation


For the first test case , the given string is "abcdef" and all the characters are unlocked.

  1. After First round of swap , the string becomes "badcfe" . Now the leftmost unlocked character is locked i.e the string is now "b_adcfe".

  2. After Second round of swap , the string becomes "b_dafce". Now the leftmost unlocked character is locked i.e string is now "bd_afce".

  3. After Third round of swap , the string becomes "bdfaec" . Now the leftmost unlocked character is locked i.e the string is now "bdf_aec".

  4. After Fourth round of swap , the string becomes "bdfeac" . Now the leftmost unlocked character is locked i.e the string is now "bdfe_ac"..

  5. After Fifth round of swap , the string becomes "bdfeca" . Now the leftmost unlocked character is locked i.e the string is now "bdfec_a".

  6. In the sixth round no more swap occur as there is only single unlocked character is left.


** ('-' is the partition , where all the characters to its left are locked characters and all the characters to it right are unlocked characters).**

Therefore , we print the string "bdfeca".

Code:


import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
class Main {

public static void main(String args[] ) throws IOException {

BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
for(int k=Integer.parseInt(br.readLine());k>0;k--){
br.readLine();
String str=br.readLine();
StringBuilder s=new StringBuilder(str);
int start=0;
int end=str.length()-1;
for(int i=1;i<str.length();i+=2){
s.setCharAt(start++, str.charAt(i));
}
for(int i=0;i<str.length();i+=2){
s.setCharAt(end--, str.charAt(i));
}
System.out.println(s);
}
}
public static void swap(StringBuilder s,int i,int j){
char c=s.charAt(i);
char d=s.charAt(j);
s.setCharAt(i, d);
s.setCharAt(j, c);
}

}


Comments

Popular posts from this blog

Terraform

Terraform is a tool for building, changing, and versioning infrastructure safely and efficiently. Terraform can manage existing and popular service providers as well as custom in-house solutions. Configuration files describe to Terraform the components needed to run a single application or your entire datacenter. Terraform generates an execution plan describing what it will do to reach the desired state, and then executes it to build the described infrastructure. As the configuration changes, Terraform is able to determine what changed and create incremental execution plans which can be applied. The infrastructure Terraform can manage includes low-level components such as compute instances, storage, and networking, as well as high-level components such as DNS entries, SaaS features, etc. The key features of Terraform are: Infrastructure as Code : Infrastructure is described using a high-level configuration syntax. This allows a blueprint of your datacenter to be versioned and

Java 8 coding challenge: Roy and Profile Picture

Problem:  Roy wants to change his profile picture on Facebook. Now Facebook has some restriction over the dimension of picture that we can upload. Minimum dimension of the picture can be  L x L , where  L  is the length of the side of square. Now Roy has  N  photos of various dimensions. Dimension of a photo is denoted as  W x H where  W  - width of the photo and  H  - Height of the photo When any photo is uploaded following events may occur: [1] If any of the width or height is less than L, user is prompted to upload another one. Print " UPLOAD ANOTHER " in this case. [2] If width and height, both are large enough and (a) if the photo is already square then it is accepted. Print " ACCEPTED " in this case. (b) else user is prompted to crop it. Print " CROP IT " in this case. (quotes are only for clarification) Given L, N, W and H as input, print appropriate text as output. Input: First line contains  L . Second line contains  N , number of

Salt stack issues

The function “state.apply” is running as PID Restart salt-minion with command:  service salt-minion restart No matching sls found for ‘init’ in env ‘base’ Add top.sls file in the directory where your main sls file is present. Create the file as follows: 1 2 3 base: 'web*' : - apache If the sls is present in a subdirectory elasticsearch/init.sls then write the top.sls as: 1 2 3 base: '*' : - elasticsearch.init How to execute saltstack-formulas create file  /srv/pillar/top.sls  with content: base : ' * ' : - salt create file  /srv/pillar/salt.sls  with content: salt : master : worker_threads : 2 fileserver_backend : - roots - git gitfs_remotes : - git://github.com/saltstack-formulas/epel-formula.git - git://github.com/saltstack-formulas/git-formula.git - git://github.com/saltstack-formulas/nano-formula.git - git://github.com/saltstack-f